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VO — Access to a specified Box folder from within IBM
Connections

Introduction

This document is designed to help you quickly and easily integrate Box into IBM

Connections. If you want to do a deeper integration with Box, our APIs are available
at http://developers.box.com.

Installation
Installing the Box for IBM Connections integration can be done by following these
steps:

1. Download the JavaScript and widget XML file from
https://cloud.box.com/s/110rol1lany874malfu5

2. Host the box JS and XML files on a server. Note that the JS file requires Dojo
to be installed so you may want to simply host it on your IBM HTTP Server:
ex: ../IBM/HTTPServer/htdocs

3. Next, you'll need to update the widgets-config.xml file. You can use the
check-out/check-in system to accomplish this or you can navigate to the
widgets-config.xml file directly: ex:
./IBM/WebSphere/AppServer/profiles/<application server
name>/config/cells/<node name>/LotusConnections-config

[ LotusConnections-config - File Browser

File Edit View Go Bookmarks Help

@ . 8 @ @ @©m & 4

Back Up Reload Home  Computer Search

Location: [/opt/lBM/WebSphere/AppServer/profiIes/AppSrvO1/config/cells/connectionswaello1/LotusConnections-config

Places ¥ x Name v  Size Type Date Modified
e -

@ root D profiles-policy.xml 3.8 KB XML document Wed 10 Oct 2¢

& Desktop | 7 profiles-policy.xsd 5.1KB XML document Wed 10 Oct 2¢

O File System | profiles-types.xmi 3.1KB XML document Wed 10 Oct 2¢

O Floppy Drive
| ] profiles-types xsd 2.8KB XML document Wed 10 Oct 20
D proxy-config.tpl 22.3 KB XML document Wed 10 Oct 2C
D proxy-config.xsd 6.0 KB XML document Wed 10 Oct 20
D search-config.xml 3.4 KB XML document Wed 10 Oct 2¢
D search-config.xsd 21.3 KB XML document Wed 10 Oct 2¢
D service-location.xsd 12.1 KB XML document Wed 10 Oct 2C
D socialmail-discovery-config.xml 1.6 KB XML document Sat 13 Oct 201
D socialmail-discovery-config.xsd 6.5 KB XML document Sat 13 Oct 201
D uiextensions-config.xml 1.7 KB XML document Wed 10 Oct 20
D uiextensions-config.xsd 3.1 KB XML document Wed 10 Oct 2C
B widgets-config.xmi 454 KB XML document Sun 20 Jan 20
[ 9 widgets-config.xsd 11.0 KB XML document Wed 10 Oct 2¢
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4. Add the widget definition to the config file under the community resource
tag:

<widgetDef defld="Box” primaryWidget="true” modes="view edit”
description="Widget to allow a community access and sharing to external
parties via Box” iconURL="http://box.com/favicon.ico”
url="http://connectionsww.demos.ibm.com/boxWidget.xml”
helpLink="http://support.box.com”/>

5. From WebSphere restart Profiles and Communities applications from your
Connections Server

Integrated Solutions Console welcome wasadmin Help | Logaut I
view: | All tasks a Enterprise Applications
Use this page to manage installed applications. A single application can be deployed onto multiple servers.
[ Guided Adtivities -
Preferences Please Wait...
[ servers —— .
e [Start! || Stop | Install te || Rollout Update | Remove File | Export || Export
New Application sl (v
B Application Types
WebSphere enterprise a pplications Select  Name < Application Status (4]
Business-level application:
You can administer the following
Services O Activities >
@ Rescurces O B]O; s >
Seaurity
00 | Common £
[E) Environmert
sal h Communities ®
e O DefaultApplication ®
O Dogear >
O Files >
Naming
O Forums >
System administration —
[ Users and Groups O Help >
[E Monitoring and Tuning O Homegage >
Troubleshoct
Sl O Metrics P>
[ service integration
e O Mobile P>
O Mobile Administration >
O Moderation >
[0 | News >
%] Profiles ®
m Coanwnb =

6. Navigate to your community and under Community Actions select Customize

7. Click on the plus to add the Box widget
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Sales Community

Stop Following this Community

Add Content

B Box + & Linked Library + &t Blog + L& Ideation Blog +
= Activities + 1. wiki + {#} Subcommunities + A Bookmarks +
Feeds + &= Files + B Media Gallery + {l} Related Communities 4+

1-12 widgetsof 12

8. Click the drop down and select Edit. Insert your Box embed iframe code into
the HTML section. Save the file.

Box

Instructions: Specify the Embed code for the folder you want to embed.
HTML:

<iframe src="https://box.com/embed_widget/O00000000000/iles
10/f/0view=expanded&sort=name&adirection=ASC&theme="blue"
width="600" height="400" mnm="0"><lm>|

Title (e.g. Box.net Files):

[Box Files |

Save Cancel

9. Log inusing your Box credentials
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Box

box

& SecureLogin

4 More Login Options
? Can't Access Your Account

-» Create an Account

Box

< All Files Greenfield Media Sales dwide Sales Q o
Worldwide Sales 4 4 Options-
= APAC H 0
W Updated Today by Kathleen Castaillac 81 & Open

4 Upload to this Folder 4
¥ Download Folder
8 share ’

Client Information
Updated Today by John Smith 81

El

Invite Collaborators
East Reglon Get Link to Folder i AddThan
Updated Today by Lauren Witlin §28

El

Send Link to Folder [':"] Folder Properties ’

& Move or Copy
West Region
Updated Today by Annie Teng 81

W Delete

El

) More Actions »
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Option 1: Access to user’s root folder

Scenario

Incorporate core Box functionality into IBM Connections to give users direct access
to all of their content in the cloud without having to leave the IBM Connections
experience. If there are specific file actions that are enabled, they will also be
accessible from within the embedded Box user experience. (There may be some
constraints/Ul issues with file actions if the widget size is too small.)

In this case, the Box embedded widget will open for the user at their root folder so
they immediately have a comprehensive view of their Box content.

Box instructions

The steps to set this up from the Box side are pretty straightforward. For a basic,
embedded root folder, copy <iframe

src="https://www.box.com/embed widget/000000000000/files/0/t/0
frameborder="0"></iframe> and paste it into step 7 of the installation guide.

Option 2: Access to consistent IBM Connections folder

Scenario

Incorporate core Box functionality into IBM Connections to give users direct access
to all of their content in the cloud without having to leave the IBM Connections
experience. In this case, the focus will be on a folder where you can store frequently
accessed content and standardized materials. If there are specific file actions that
are enabled for IBM Connections, they will also be accessible from within the
embedded Box user experience. (There may be some constraints/Ul issues with file
actions if the widget size is too small.)

In this case, the Box embedded widget will open for the user at a folder dedicated to
IBM Connections so users immediately have view of Box content relevant to that
community. In addition, users will be able to navigate to their root folders to access
all of their Box content. Alternatively, as an admin, embedded Box can be pointed to
an existing folder if it makes more sense for the use case.

A deeper integration with Box is also possible using our APIs. These can be used to
programmatically create and generate the embed code for folders. API
documentation is available at http://developers.box.com.

Box instructions
The steps to set this up from the Box side are pretty straightforward.
1. Create afolder in the Admin root directory called IBM Connections (or
something related to IBM Connections).
2. Invite all users that should have access (at a minimum, all users who have
access to IBM Connections) as collaborators to that folder.
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3. Select that folder in Box and right click or click on “Folder Options”-> Share -
> Embed Folder in Your Site

b Upload | < New... -

L Folder Options

)

Sortby: Date ~ 0

Invite Collaborators

Get Link to Folder

Send Link to Folder
Embed Folder in Your Site
Disable Shared Link

share # K4 O
& Open

& New Folder

4 Upload to this Folder
¥ Download Folder

C& Share

[E> Add Tags

@ Sync Folder to Desktop
£3 Folder Properties

(& Move or Copy

W Delete

) More Actions

4 Upload to this Folder
¥ Download Folder

ftivities”™

G& Share

[E> Add Tags

@ Sync Folder to Desktop
£3 Folder Properties

(& Move or Copy

Invite Collaborators

Get Link to Folder

Send Link to Folder
Embed Folder in Your Site
Disable Shared Link

& Delete
D More Actions

4. Set preferences for the embedded folder, including size, cooler, etc. Copy the
URL as created by Box once the settings are confirmed.
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Share Great folder for testing t... UpesAncaes I
Link Send Post = [7] Embed Mobile
Size: View:
Medium H List H
Width: Sorting:
Name H
Height: Theme:
Blue =
Embed code: Preview this embed @
<iframe

' src="https:/www.box.com/embed_widget/4c1a88851593/s/70244d780785fd07b517
?view=expanded&sort=named&direction=ASC&theme=blue" width="500"
height="400" frameborder="0"></iframe>

Copy to Clipboard Close

To add the folder to your home page, follow the instructions listed in the installation
process. Instep 7, use the obtained in the Box Ul:

Box Embed Code:

<iframe src="https://www.box.com/embed_widget/4c1a88851593/s/
https://www.box.com/embed_widget/81a8e7b1f099/s/70244d780785fd0
7b5177?view=expanded&sort=name&direction=ASC&theme=Dblue"
width="500" height="400" frameborder="0"></iframe>

Appendix: Parameter options for the Widget

Below is a list of the current parameters that you can pass to the widget.
Example embed widget iframe:

<iframe
src="https://www.box.com/embed_widget/123456789012/s/0190ee4f6f7c8b012
345%view=expanded&sort=name&direction=ASC&theme=Dblue" width="500"
height="400" frameborder="0"></iframe>

Acceptable Widget URL Structure

e https://www.box.com/embed_widget/<widget hash>/s/<shared_name>
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e https://<custom_subdomain>.box.com/embed_widget/<widget_hash>/s/<s
hared_name>
e https://www.box.com/embed_widget/000000000000/files/0/1/0

e https://<custom
subdomain>.box.com/embed_widget/000000000000/files/0/f/0

<widget_hash> are 12-character alphanumeric (lowercase) strings that is used to
store configurations about the widget. This hash does not actually hold any secure
information about the user, it is used primarily for saving the view, sort, root folder,
and theme of the widget.

The widget_hash is typically generated at the time of creation. It is merely used to
retain display configurations for the widget and is arbitrary. Here are some example
widget hashes:

widget_hash = 123456789012 is a valid hash

widget_hash = alb2c3d4e5f6 is also a valid hash

Since the <widget_hash> cannot be obtained easily, all zeros will work as well.

<shared_name> is the shared url identifier that is found when sharing a link.

For example, on the Box Website, right-click on the target folder and click on Share
=> Get Link to Folder. This will show you a popup with something

like https://www.box.com/s/0190ee4f6f7c8b012345, the shared_name would

be 0190ee4f6f7c¢8b012345. Please note that the HTML folder only works for shared
folders (which means no files/webdocs,gsheet, etc)

Thus a full example would

be https://www.box.com/embed widget/123456789012/s/0190ee4f6f7c8b01234
5 given that the shared_name 0190ee4f6f7c8b012345 exists and is openly
accessible. If the shared link has restrictions on it such as collaborator access only,
then the user will be prompted with a login screen. (Please note that for security
reasons, we will be moving towards a popup login screen where the URL is visible
as box.com).

Configuration Params (passed as a GET param)
view

Accepted Values:

[list, icon]

Note: "expanded" is also accepted which is actually the same as list. We use it in the

webapp, but external users can definitely just use list.
Description:
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Changes the default layout of the files listings to a list view or an icon view. This

setting persist throughout their session and can be modified via the "Options" Menu.
"Options"=>"View"=>"As List" or "As Icons"

sort
Accepted Values:
[name, date, size]

Description:

Changes the default sorting of files. This setting persist throughout their session and
can be modified via the "Options” Menu. "Options"=>"Sort"=>"Date" or "Name" or
"Size"

direction
Accepted Values:
[asc, desc] - ascending/descending respectively

Description:

Changes the default sort direction of files. This setting persist throughout their
session and can be modified via the "Options” Menu. "Options"=>"Sort" and clicking
on the existing sort will modify the direction

theme
Accepted Values:
[blue, gray]

Note: 'gray' (American) not 'grey" (British)

Description:
Changes the default color scheme. This setting will persist throughout the widget.
The gray theme is intended to be more neutral.

Sizing Parameters
width and height parameters are required on the actual iframe and are not passable
as GET params.

width

Accepted Values:

min supported value: 330px

max supported value: no limit but we recommend a max of 12000px, 100% can be
used but we do not openly support percentage width widgets.

Comments:
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This determines both the size AND functionality of the widget. Smaller widgets

(<500px) have less functionality than Medium widgets (500px=>799px) which also
have less functionality than large widgets (>=800px)

Example: Commenting and edit-in-place is disabled for smaller widgets

height

Accepted Values:

min supported value: 400px
max supported value: no limit

Comments:

Height does not affect functionality.

"supported value" implies that we do not fix issues for widgets smaller than 330px.
At this time, we only fully support Medium and Large widgets. Small Widgets
are still being worked through.

In addition, we recommend adding frameBorder="0" to the iframe so width
calculations work correctly on all browsers.
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